vulnerability dx_2020